colour.utilities.describe_environment

colour.utilities.describe_environment(runtime_packages=True, development_packages=False, extras_packages=False, print_environment=True, **kwargs)[source]

Describes Colour running environment, i.e. interpreter, runtime and development packages.

Parameters
  • runtime_packages (bool, optional) – Whether to return the runtime packages versions.

  • development_packages (bool, optional) – Whether to return the development packages versions.

  • extras_packages (bool, optional) – Whether to return the extras packages versions.

  • print_environment (bool, optional) – Whether to print the environment.

  • padding (unicode, optional) – {colour.utilities.message_box()}, Padding on each sides of the message.

  • print_callable (callable, optional) – {colour.utilities.message_box()}, Callable used to print the message box.

  • width (int, optional) – {colour.utilities.message_box()}, Message box width.

Returns

Environment.

Return type

defaultdict

Examples

>>> environment = describe_environment(width=75)  
===========================================================================
*                                                                         *
*   Interpreter :                                                         *
*       python : 3.8.6 (default, Nov 20 2020, 18:29:40)                   *
*                [Clang 12.0.0 (clang-1200.0.32.27)]                      *
*                                                                         *
*   colour-science.org :                                                  *
*       colour : v0.3.16-3-gd8bac475                                      *
*                                                                         *
*   Runtime :                                                             *
*       imageio : 2.9.0                                                   *
*       matplotlib : 3.3.3                                                *
*       networkx : 2.5                                                    *
*       numpy : 1.19.4                                                    *
*       pandas : 0.25.3                                                   *
*       pygraphviz : 1.6                                                  *
*       scipy : 1.5.4                                                     *
*       tqdm : 4.54.0                                                     *
*                                                                         *
===========================================================================
>>> environment = describe_environment(True, True, True, width=75)
... 
===========================================================================
*                                                                         *
*   Interpreter :                                                         *
*       python : 3.8.6 (default, Nov 20 2020, 18:29:40)                   *
*                [Clang 12.0.0 (clang-1200.0.32.27)]                      *
*                                                                         *
*   colour-science.org :                                                  *
*       colour : v0.3.16-3-gd8bac475                                      *
*                                                                         *
*   Runtime :                                                             *
*       imageio : 2.9.0                                                   *
*       matplotlib : 3.3.3                                                *
*       networkx : 2.5                                                    *
*       numpy : 1.19.4                                                    *
*       pandas : 0.25.3                                                   *
*       pygraphviz : 1.6                                                  *
*       scipy : 1.5.4                                                     *
*       tqdm : 4.54.0                                                     *
*                                                                         *
*   Development :                                                         *
*       biblib-simple : 0.1.1                                             *
*       coverage : 5.3                                                    *
*       coveralls : 2.2.0                                                 *
*       flake8 : 3.8.4                                                    *
*       invoke : 1.4.1                                                    *
*       jupyter : 1.0.0                                                   *
*       mock : 4.0.2                                                      *
*       nose : 1.3.7                                                      *
*       pre-commit : 2.1.1                                                *
*       pytest : 6.1.2                                                    *
*       restructuredtext-lint : 1.3.2                                     *
*       sphinx : 3.1.2                                                    *
*       sphinx_rtd_theme : 0.5.0                                          *
*       sphinxcontrib-bibtex : 1.0.0                                      *
*       toml : 0.10.2                                                     *
*       twine : 3.2.0                                                     *
*       yapf : 0.23.0                                                     *
*                                                                         *
*   Extras :                                                              *
*       ipywidgets : 7.5.1                                                *
*       notebook : 6.1.5                                                  *
*                                                                         *
===========================================================================